Python中国社区  »  Django

Django 2.0 发布,不再支持 Python 2.x!

小象 • 7 月前 • 194 次点击  

Python Web 框架 Django 发布 2.0 版本。该版本不再支持 Python 2.x,并添加了一大串新功能。另,Numpy 库官方宣布准备放弃支持 Python 2

关于版本兼容性问题:

  • Django 2.0支持Python 3.4,3.5和3.6

  • Django 1.11.x是支持Python 2.7的最后一个版本。

  • Django 2.0是最后一个支持Python 3.4的版本,并且只支持到2019年4月,到时如果你仍然计划使用Python 3.4,可以用Django 1.11 LTS(支持到2020年4月)。 不过需要注意的是,Python 3.4的使用期限是2019年3月。

主要更新:

1、简化 URL 路由语法:新的 django.urls.path() 允许使用更简单,更易读的 URL 路由语法。例如:

原来:

url(r'^articles/(?P[0-9]{4})/$', views.year_archive),

现在

path('articles//', views.year_archive),

2、对移动端友好的 contrib.admin:admin现在响应和支持所有主要的移动设备。

3、Window expressions:新的 Window expression 允许向查询集添加 OVER 子句。

完整的更改和弃用可查阅发行说明:https://docs.djangoproject.com/en/2.0/releases/2.0/

下载地址:https://www.djangoproject.com/download/

-END-



今天看啥 - 高品质阅读平台
本文地址:http://www.jintiankansha.me/t/lbpg8VyIkt
Python社区是高质量的Python/Django开发社区
本文地址:http://www.python88.com/topic/4427
 
194 次点击  
分享到微博