Python社区  »  Git

我无法从R中的github下载包BMR,它给出了一个错误:

Alina • 2 周前 • 40 次点击  
> library(devtools)

Download required package: usethis

Warning messages:
1: package ‘devtools' was built under R version 3.5.3 
2: package ‘usethis’ was built under R version 3.5.3 

> install_github("kthohr/BMR",force=TRUE)
Downloading GitHub repo kthohr/BMR@master
√  checking for file 'C:\Users\Asus\AppData\Local\Temp\RtmpqkzAt0\remotes4b403a3737ba\kthohr-BMR-63565cd/DESCRIPTION' ... 
-  preparing 'BMR': (3.1s)
√  checking DESCRIPTION meta-information ... 
-  cleaning src
-  checking for LF line-endings in source and make files and shell scripts (1.1s)
-  checking for empty or unneeded directories (362ms)
-  looking to see if a 'data/datalist' file should be added
-  building 'BMR_0.11.0.tar.gz'

Installing package into ‘C:/Users/Asus/Documents/R/win-library/3.5’
(as ‘lib’ is unspecified)
* installing *source* package 'BMR' ...
** libs
Ошибка: (конвертировано из предупреждения) this package has a non-empty 'configure.win' file,
so building only the main architecture
* removing 'C:/Users/Asus/Documents/R/win-library/3.5/BMR'
In R CMD INSTALL
Error: Failed to install 'BMR' from GitHub:
  (converted from warning) installation of package ‘C:/Users/Asus/AppData/Local/Temp/RtmpqkzAt0/file4b4017187131/BMR_0.11.0.tar.gz’ had non-zero exit status
Python社区是高质量的Python/Django开发社区
本文地址:http://www.python88.com/topic/56513
 
40 次点击  
分享到微博
文章 [ 1 ]  |  最新文章 2 周前
ashwin agrawal
Reply   •   1 楼
ashwin agrawal    5 月前

试试这个:

install.packages("devtools")
library(devtools)
install_github("kthohr/BMR",force=TRUE)